Welcome to the BukkitWiki!

This Wiki is home to Bukkit's documentation and regulations surrounding the Bukkit Project and it's services. Want to help out? We would love to have you! Signup to get started!



Updating links (03/04/15)[]

The link to dl.bukkit.org is dead since the DMCA issue.

We should edit it with the new bukkit setup procedure, the one including obtaining latest non DMCA-affected jarfile and patching it.

Max OS X Daemon Instructions? (09/12/2014)[]

I would like to see instructions on how to make a Daemon out of the .command file so I don't have to be logged into the Mac 24/7.

Inclusion into Docs Nomination (06/05/2012)[]

Please Discuss the Docs Nomination here. I'm alright with including it as long as we split the pages into Windows, Linux, and Mac Install Instructions. resba - BukkitWiki Admin 18:20, 5 June 2012 (EST)

Page Protection Notice (Updated 06/05/2012, Removed 06/05/2012)[]

The page associated with this talk page has been locked due to counter-productive editing. In addition: Community tutorials should not be considered the Universally Reccomended method because it nullifies the use of this page. If you don't agree with the edits of a user, inquire on their talk page the reasoning behind it OR start a conversation on that page's talk page. This page's protection will expire in one week of this posting. If this continues I will lock it permanently and additions to the tutorial will have to be requested on the talk page. resba - BukkitWiki Admin 12:58, 31 January 2012 (EST)

The page associated with this talk page has been locked indefinably due to being a high-traffic page. Edits can be discussed on this page and added by an administrator. resba - BukkitWiki Admin 07:34, 2 February 2012 (EST)
Locking this page isn't useful. The documentation with respect to Linux is embarrassing at best. If you can't handle dealing with vandalism, just delete the thing or at least give pointers to some forum threads. -- Dagmar d'Surreal 13:18, 25 February 2012 (EST)
Page has been unlocked due to demand and nomination for inclusion into docs. resba - BukkitWiki Admin 18:19, 5 June 2012 (EST)

Two major problems with the Mac Instructions[]

First of all, on mac step 3.2, before saving the file, the user must go to Format > Make Plain Text in order fo the command to work.

Also, in the Mac Alternate Method is not up to date, on the line: mv craftbukkit-1.1-R3.jar CraftBukkit.jar The line says 1.1-R3, while the current version is 1.2.5.

Try to fix the problems ASAP, because both of the Mac methods fail to work due to the problems.

--Assisstion 05:14, 22 April 2012 (EST)

Minor Problem in Mac Instructions[]

This isn't a huge fix. In the Mac OSX instructions under the section that says "ALTERNATE METHOD" there is a line that reads as follows:

Textedit should open a document called "LaunchServer.command".

when the line should read as:

Textedit should open a document called "start.command".


The main download link goes direct to a 404-not-found page.

The second download link (under linux) goes to some lamearse graphic telling everyone that "read permission" is not granted, or some other similar bogus message (yes - I clicked "Allow"...)

Further cleanup and streamline. Slaps to those using bash for portable scripts. --AnrDaemon 22:24, 27 March 2011 (EST)
Dude, no "reasonable" Linux distribution out there doesn't have bash in it. Heck, you can generally expect even Solaris machines to have bash now. -- Dagmar d'Surreal 13:24, 25 February 2012 (EST)
Cleaned up the Windows startup script. %ProgramFiles% has the same end result for both x86 and x86-64 systems, unless, as note on page specified, you are running a 32-bit Java machine on x86-64. Also separated base path extraction from server startup. While it does not affect example directly, it opens a way to improve script in some interesting ways... --AnrDaemon 20:55, 13 March 2011 (EST)
Reworded note about jar file name matching downloaded name. The existing text was incorrect and confusing users. Unfortunately, now it doesn't fit in the code window. Also: can anyone confirm that on a 64 bit machine java is actually installed in the program files(x86) folder, as listed here? This seems unlikely. I will double check tomorrow and update if necessary. I also reformatted this page a bit.--Mughi 19:14, 20 February 2011 (EST)

Someone forgot to put in steps for giving a PATH variable in Windows. A .bat file with only those commands in it won't work unless you have a path for java set up in your system variables, or unless it's declared in the . bat script. --unknown user

The page says to download craftbukkit... It might be useful to have a link pointing to the latest stable version??? --Mr FJ 09:51, 18 January 2011 (MST)

Someone left </source> at the end of the linux shell script. This resulted in:
./run.sh: line 2: syntax error near unexpected token `newline'
./run.sh: line 2: `cd "${0%/*}"; java -Xms512M -Xmx1024M -jar craftbukkit-0.0.1-                                                  SNAPSHOT.jar</source>'

I corrected the error. --unknown user

Seems to have popped up again due to copyright infringement. I looked at the GitHub for the supposed source code and... No .jar file to be seen and so I am out of my depth. http://dl.bukkit.org/dmca/notification.txt Vain.3805 -Talk -Stuff 04:19, 21 October 2014 (UTC)

Need Mac instructions[]

Can someone with a Mac please confirm that the instructions for Linux also work on Macs.

It doesnt work. Please rewrite.--SmiVan 18:43, 04 March 2011
I made one for this thread: http://forums.bukkit.org/threads/how-to-install-bukkit-newb-friendly.245/ And adapted it for here :)-PierreLouis 11:47, 06 March 2011
Please be sure to sign your name properly by using the signature button in the toolbar. 4am 12:42, 3 September 2011 (EST)
I just added a new mac instruction --Sagacious Zed 13:04, 1 December 2011 (EST)
Under the section 3. Obtaining startup script it needs to be noted that when pasting the startup script into TextEdit users should convert the file to plain text before saving by selecting the menu option Format>Make Plain Text. By default, TextEdit creates a rich text document that will not work properly as a unix script without converting to plain text. --MrMalm 23:24, 1 March 2012 (EST)
Noted --Sagacious Zed 21:26, 5 June 2012 (EST)
The mac download instruction doesn't work. curl -O http://cbukk.it/craftbukkit.jar does not fetch any data, even though the direct URL from a browser seems to work. The command-line command that works, and the one that is used by the main page is the following: curl -LO http://dl.bukkit.org/latest-rb/craftbukkit.jar I made this change, but it was reverted for some reason by Mbaxter to the non-working version. Jellyvista 23:12, 22 September 2012 (EST)
Without documentation you edited the URL to a different one. I'm updating the command to curl -LO, as that works fine with the existing URL. Sorry for the confusion. - mbaxter 02:09, 23 September 2012 (EST)

Please don't spam[]

I removed a link to MCMSC.com, The BukkitWiki is not your personal ad space. I am going to move to have the user who posted this link banned if it happens again. Consider yourself warned. 4am 12:40, 3 September 2011 (EST)

In regards to > sign[]

In the bash scripts, the terminal relys on > If someone were to copy what is rendered however is > which breaks the script. --Sagacious Zed 13:02, 1 December 2011 (EST)

Adf.ly Links Not Permitted[]

There is no reason they should not be permitted. In this scenario, the setup they link to is invaluable in helping people setup a Minecraft server with ease. The five seconds you wait for (which supports the creator) is nothing compared to the relatively vast amount of work you must do as an alternative, which is neither helpful to those new to setting up servers or those who have setup servers before. In addition, the installer is universal and can be used on any operating system.

Perhaps the moderators should realize there is no reason to over-complicate things.

Bukkit's policy is to disallow ad.fly links, not BukkitWiki's. This is final, don't do it again. resba - BukkitWiki Admin 12:00, 13 January 2012 (EST)
You are welcome to post non-adfly or other money-link services links to these auto-installers. But if you have an issue with the policy itself feel free to discuss this policy with administration --NuclearW 17:13, 13 January 2012 (EST)

Problem in Linux section[]

The script still doesn't make sense. The current script is:

 BINDIR=$(dirname "$(readlink -fn "$0")")
 cd "$BINDIR"
 java -Xms1024M -Xmx1024M -jar craftbukkit.jar -o true

As far as i can tell, this will set BINDIR to the directory of the script, then cd to that directory, which it's already in.
It seems quite pointless
Shouldn't the script contain just the 'java' command (and the top line)?
Shelvacu 00:07, 22 February 2013 (EST) Edit: I've also noticed the Mac guide also has this, but simplified to 'cd $(dirname "$0")' which doesn't seem needed either.

Recommended Build Number[]

This page hasn't been updated to say what the latest craftbukkit version is. It says 1.1-R4, but the link for download goes to 1.1-R6.

More java details.[]

Just noticed it locked, but maybe some information could be added about java?

For example a link to the java site, and a 'comparison' of java versions. 64 bit is better as 32 (if your system supports it) and supports more RAM. JRE7 is better at performance, improved generally compared to JRE6. Also 32bit is restricted to 1GB RAM, that isn't mentioned.

I think these could be usefull.

Bertware 13:21, 23 March 2012 (EST)

This would be quite useful. I would like an admin to include this Shelvacu 00:15, 22 February 2013 (EST)

-- 10:40, 6 July 2017 (UTC)== Edit in Windows ==

The third text box should say

CD /D "%~dp0"
java -Xmx1024M -Xms1024M -jar craftbukkit.jar

This makes it easier... sort of

Error in Windows run.bat[]

The text box should say

java -Xmx1024M -Xms1000M -jar craftbukkit.jar -o true

Otherwise it won't launch, with no minimum RAM allocation

Windows trouble[]

When I run RUN.bat it says: "unable to access jar file" Please help

I also get this error! I seem to be unable to find a sollution Dx.



I am having the same problem as the person above me.

When I run the RUN.bat file, it comes up with 'Error: Unable to access jarfile craftbukkit.jar'

I used the Java-7 code for the file:

"%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit.jar
This page is not for Bukkit Support. Please ask your questions either on IRC or on the bukkit forums. Thank you - Chris Ward - Wiki Admin (Report Spam/Contact) 03:20, 2 August 2012 (EST)



Hello! I am having trouble naming the txt document "run.bat". It says That quotes cannot be used in the file name, so after re-trying multiple times, I decided to try double apostrophes to see if that worked, but it still saved as a run.bat.txt file. By the way, I am using Windows 8, so It may just be a problem with that..Anyways, Thanks for the Help Oh By the way, with the help of a friend I fixed that problem, and have also ran into a new one..I need simpler instructions to adding Java to my system path...I have tried and retried the thing 5 times but still cannot get it to recognize Java. Please Help with this!

Hello! I had had the same problem as you guys, and I found out a solution.


java -Xmx1024M -jar craftbukkit.jar -o true PAUSE


java -Xmx1024M -jar craftbukkit.jar -o true PAUSE


Change craftbukkit.jar to your .jar name. In my case, I changed craftbukkit.jar to craftbukkit-1.8.3-R0.1-SNAPSHOT-latest.jar.


java -Xmx1024M -jar craftbukkit-1.8.3-R0.1-SNAPSHOT-latest.jar -o true PAUSE

Hope I helped! - Ascouda

Remove Auto-Installer[]

The topic for the auto-installer has had its links removed for "Making money off of an open-source project without validation of integrity." Since no one but mods / admins can edit this article, I will be leaving this note here. Iyeru 20:04, 9 April 2012 (EST)

"Advanced" tutorials and scripts[]

I added an improved Windows .bat and marked it as such. The edit was reverted given the reason "this is a basic tutorial not a madhouse". While I'm fine with it being a basic tutorial, I feel that the principle should either exist globally or not at all. The Mac heading has an Advanced section in much the same vein as my contribution (to improve ease of use), and I think that if that is permitted then mine should also... or neither should. Perhaps advanced tips should have their own page, if they don't belong here? --Joequincy 22:54, 14 October 2012 (EST)

The advanced section of the Mac OS X instructions is not a start up script. It is merely the way to perform all the action in the basic setup through the terminal. --Sagacious Zed 20:08, 15 October 2012 (EST)

Obtaining Startup Script Mac Problem[]

When you copy and paste the text for the start_server.command file it doesn't work. You have to delete the line breaks and manually enter them yourself in text edit, otherwise it results in:

... -bash: /Users/.../start_server.command: /bin/bash^M: bad interpreter: No such file or directory logout

[Process completed]

This was not easy for a beginner to figure out. --Clockbound 10:57, 5 November 2012 (EST)

I have corrected the problem with the following User:Sagacious Zed/MacOSX startup script, awaiting for an administrator to either copy the source or move it out of my user page and include it into the page. --Sagacious Zed 13:46, 5 November 2012 (EST)
Mbaxter has updated the script on the page, it should have fixed the problem (invisible characters) --Sagacious Zed 16:00, 6 November 2012 (EST)

rfwadmin Linux server admin[]

For the Linux servers section, how about mentioning my rfwadmin startup script and web interface? Thuejk 14:08, 22 December 2012 (EST)

BukkitWiki is not a place for advertisment. -- Chris Ward - Wiki Admin (Report Spam/Contact) 02:12, 23 December 2012 (EST)
That is good to know, but how is that relevant here? If you think rfwadmin is genuinely the best way to run a free web interface for a bukkit server, mentioning it is not advertisement. I am OK with you not mentioning it if you think it is not a good solution, but not mentioning it because you think I am self-promoting it (which I am), even though it is the best solution (which you are free to think it is not once you have evaluated it), is silly. Note that rfwadmin is free, so I am not making money off it. Thuejk 08:25, 23 December 2012 (EST)

Server works but can NOT actually join server. :([]

I have the server installed and it seems to be working when looking at the terminal window, but when I try to connect to it using my public IP address, there's an X over the signal bars. It does NOT say "Can't connect to server." It shows the amount of people currently in/able to join (mine currently is 0/10) and to the left of the X over the signal bars, it says "1.4.5" in red lettering. Please help!

This is not a place for support. If you need help, see the Bukkit forums at http://forums.bukkit.org - mbaxter 13:03, 1 January 2013 (EST)

Video Tutorial for Windows and Mac OS X[]


Just thought I'd post this here if anyone needs it. I made a video tutorial on how to set up a Bukkit server. It'd be great if the admins could include it in the community guides section! :D

Where's 1.5?[]

Hello. Superleximus here and I'm asking "Why is there no Bukkit for 1.4.5? I can't find one. Can anyone help?


Edit proposal: "Advanced Setup"[]

The proposed change is to add this to the bottom of the page:

== Advanced Setup ==
If you want more options in your server setup, look at [[Bukkit.yml]],
the server.properties file, [[CraftBukkit Command Line Arguments]], and
[http://docs.oracle.com/javase/tutorial/essential/environment/cmdLineArgs.html Java command line arguments].

Help with Bat file[]

Whenever I run the .bat it pops up with this;

'java' is not recognized as an internal or external command,
operable program or batch file.

Please help! Riking (talk) 02:16, 29 June 2013 (UTC)

Offline mode[]

The providing of -o in the arguments for the startup script is a tad confusing. I know personally I didn't know what the -o argument was when I was setting up my server and it took me ages to figure out why I couldn't start it in offline mode. Perhaps add a note at the bottom?

Edit Recommended to Notes[]

There can be issues with getting an error stating that the jarfile cannot be accessed when running the created batch file. The fix to this is quite simple- the .jar extension is hidden, and the existing .jar extension is redundant(craftbukkit.jar.jar). Deleting this redundent extension making it appear to be simply craftbukkit fixes this issue. Credit for this fix belongs to Deonasoto, though this post is by Eranderil. Thanks Deonasoto!

Example error prompt: ERROR: unable to access jarfile craftbukkit.jar

Deonasoto's full explination: https://forums.bukkit.org/threads/unable-to-access-jarfile-craftbukkit-jar.103467/

i just have NO idea[]

i wanted to make a bukkit minecraft server, and it all went well, i had to add java to the system path but once i did that i was fine... or so i thought. Now it accepts java as a command, but it has a new error message. "Error: Unable to access jarfile craftbukkit.jar"

your guide doesn't have anything on this, it may be that i am on windows 8 or something. But i still want my server to be up and running. I just started this today and like how far ive gotten, but i cant seem to go further. Anything on this would be useful. XD

Problem for Java.lang.outofmemory :permgen space[]

The problem spawned for class load (plugins) in Overload mode in space don't loaded.Need edit the launch script
For Windows Repair idea
@Echo off
java -XmsXXXm -XmxXXXm -XX:MaxNewSize=256m -XX:MaxPermSize=256m -jar <Name Server>.jar
For Linux Repair Idea
"%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -XX:MaxNewSize=256m -XX:MaxPermSize=256m -jar craftbukkit.jar
The Problem in Tomcat also have this Problem,so please edit the launch script Start.sh (For Windows,please edit this Launch.bat)

Failed to load Main-Class manifest attribute from bukkit-1.7.9-R0.1.jar[]

Failed to load Main-Class manifest attribute from bukkit-1.7.9-R0.1.jar How do i fix this?

There's a solution to this in the Troubleshooting Common Problems article. JWhy (talk) 17:18, 10 January 2015 (UTC)

Starting up server problems..[]


If I run the .bat file it says "no main manifest attribute, in bukkit-1.6.4-R2.0.jar"

I don't know what's wrong..

The code I used in the .bat file is

"java -Xmx1024M -jar bukkit-1.6.4-R2.0.jar -o true

And the file is called "bukkit-1.6.4-R2.0.jar"

My OS is Windows 8.1

Can somebody help me???


Revin 12:02, 31 January 2015 (UTC)

You can't use any bukkit.jar to start a Minecraft server, you'll have to find a craftbukkit.jar and put it in place JWhy (talk) 12:22, 1 February 2015 (UTC)

I Can't download CraftBukkit[]

Is 'dl.bukkit.org' offline? I can't download the CraftBukkit JAR file!

CraftBukkit is not legally available for download anymore. There's a statement from the COO of Mojang.

PermissionsEX nodes not working?[]

Well, Ive looked at every node and put it in the permissionsEX .yml file.

Here is a screenshot.


   default: true
   prefix: '&8[&fMember&8] &f'
   - msg
   - mail
   - m
   - r
   - reply
   - afk.auto
   - balance
   - balancetop
   - chat.question
   - delhome
   - help
   - home
   - ignore
   - info
   - itemdb
   - kit
   - list
   - mail.send
   - motd
   - msg
   - pay
   - rules
   - realname
   - sethome
   - signs.use.buy
   - signs.use.free
   - signs.use.info
   - signs.use.kit
   - signs.use.mail
   - signs.use.protection
   - signs.use.repair
   - signs.use.sell
   - signs.use.time
   - signs.use.trade
   - signs.use.warp
   - signs.use.weather
   - spawn
   - tpa
   - tpaccept
   - tpahere
   - tpdeny
   - warp
   - warp.list
   - world
   - banknotes.*
  1. Random:
   - randomtp.sign.use
   - randomtp.portal.use
   - randomtp.portal.info
  1. clickwarp
   - clickwarp.warps
   - clickwarp.warp
   - clickwarp.invwarp
   - clickwarp.invwarp.item
   - clickwarp.sign.use
   - clickwarp.warp*
     default: false
     prefix: '&f[&aVIP&f] '
   - essentials.back
   - essentials.sell
   - essentials.signs.use.trade
   - essentials.signs.use.sell
   - essentials.signs.create.trade
   - essentials.signs.create.sell
   - essentials.nick
   - essentials.nick.color
   - essentials.nick.format
   - player
     default: false
     prefix: '&f[&c&lMod&f] '
   - essentials.ban.*
   - essentials.broadcast
   - essentials.give
   - essentials.item
   - essentials.eco
   - essentials.clearinventory.others
   - essentials.clearinventory
   - essentials.vanish.see
   - essentials.essentials
   - essentials.kick
   - essentials.kick.notify
   - essentials.kill
   - essentials.mute
   - essentials.mute.notify
   - essentials.tempban
   - essentials.weather
   - essentials.unban
   - essentials.unban.notify
   - donator
   - '*'
   - essentials.*
   - essentials.god.*
   - essentials.signs.break.buy
   - essentials.signs.break.free
   - essentials.signs.create.free
   - essentials.signs.create.warp
   - essentials.signs.break.warp
   - essentials.signs.break.disposal
   - essentials.signs.create.disposal
   - vault.admin
   - lagg.*
   - moderator
     prefix: '&f[&e&lOWNER&f] '
     default: false  


   - Owner
   - permissions.*
     name: monpetitchien


Anyway in the server if you are not OP it will not let you warp or anything?

It would be greatly appreciated if you guys could try and help for this is ruining my server!

Thanks in advance!